« PostgreSQLでdblink | Main | InterTrac »

2009.01.30

PostgreSQL JDBCドライバの各バージョン

 配布されているソースコードは1種類ですが、バイナリダウンロードの場合はJDKのバージョンにあわせて選択するPostgreSQLのJDBCドライバ。その実体はどの程度違うんだろう・・・と思っていたのですが、たまたまJDBCドライバのソースを眺める機会があったので解決。

 Antでビルドする際のオプションにより、最終的にどのドライバを利用するClassファイル群ができあがるかが異なってきているようです(ビルドする際に、ソースコード(の元となるもの)内のテキストの置換を行っています)。

#単純にソースファイル一式をEclipseに取り込んだだけではコンパイルエラー出まくり(^^; 

|

« PostgreSQLでdblink | Main | InterTrac »

DB」カテゴリの記事

Java」カテゴリの記事

Comments

Post a comment



(Not displayed with comment.)


Comments are moderated, and will not appear on this weblog until the author has approved them.



TrackBack

TrackBack URL for this entry:
http://app.cocolog-nifty.com/t/trackback/3959/43843513

Listed below are links to weblogs that reference PostgreSQL JDBCドライバの各バージョン:

« PostgreSQLでdblink | Main | InterTrac »