« Trac Plugin - IRequestFilter | Main | Pythonでxmlrpc »

2008.09.24

Trac 0.11 rc1 -> Trac0.11.1へのアップデート

 あるところで使用しているTracが0.11-rc1(shuwa-ja)のままだったので、0.11.1-ja1に更新しました。

 ・・・どのページを開こうとしても、UnicodeDecodeError(だったと思う)が発生(汗)。0.11.1-ja1で新規に作成したプロジェクトは問題なく表示できることから、0.11-rc1で作成したデータベース(あるいは設定ファイル)に原因があると推測。

・試しに、Trac0.11.1で作成したiniファイルに変更して見ると問題なく動作する
  ⇒iniファイルに問題があると判断

ってことで、2つのiniファイルを見比べてみると・・・かなり項目が増えていますね。で、その中で処理を行うクラスを定義している(と思われる)ものもあったので、それが原因かと。Trac0.11.1で作成したiniファイルに対して、従来使用していたiniファイルの内容をコピーして完成させたiniファイルを使用すると、問題なく動作するようになりました。

#Unicodeのエラーが出ていたのは、Trac-0.11.1.ja1でエラー発生時にエラー(?)あたりが関連しているのかも知れません。

|

« Trac Plugin - IRequestFilter | Main | Pythonでxmlrpc »

Subversion・Trac・etc.」カテゴリの記事

Comments

Post a comment



(Not displayed with comment.)


Comments are moderated, and will not appear on this weblog until the author has approved them.



TrackBack

TrackBack URL for this entry:
http://app.cocolog-nifty.com/t/trackback/3959/42550206

Listed below are links to weblogs that reference Trac 0.11 rc1 -> Trac0.11.1へのアップデート:

« Trac Plugin - IRequestFilter | Main | Pythonでxmlrpc »