« TestLink:LDAPで認証 | Main | Trac一括チケット登録 »

2008.05.28

MERGEリクエストが失敗しました

Subversionでコミットする際に、毎回「MERGEリクエストが失敗しました」のメッセージがでてエラーが出るという現象に遭遇。ただ、ログを見てみるとコミット自体は完了している模様。調べてみると、「post-commit」スクリプトでエラーが出た場合にそういう状況になる場合があるとのこと。

シェルからpost-commitスクリプトを手動で実行してみると

/usr/local/share/python2.5.1/lib/python2.5/site-packages/matplotlib/__init__.py:753: UserWarning: This call to matplotlib.use() has no effect
because the the backend has already been chosen;
matplotlib.use() must be called *before* pylab, matplotlib.pyplot,
or matplotlib.backends is imported for the first time.

warnings.warn(_use_error_msg)


といったメッセージが。

どうも、MetrixPlugin関連のファイルをインストールしたときからの現象っぽい。

トレースに表示されている__init__.pyファイルの

from __future__ import generators

の次の行に
from pylab import *

を記述して解決。

|

« TestLink:LDAPで認証 | Main | Trac一括チケット登録 »

Subversion・Trac・etc.」カテゴリの記事

Comments

実はこの修正を行ってしまうと、TracMetrixPluginが動作しなくなってしまいます(^^;

両方とも問題なく動作する方法に関して現在模索中・・・。

Posted by: syo | 2008.06.19 22:50

Post a comment



(Not displayed with comment.)


Comments are moderated, and will not appear on this weblog until the author has approved them.



TrackBack


Listed below are links to weblogs that reference MERGEリクエストが失敗しました:

» TracMetrixPlugin [気の向くままに・・・]
MERGEリクエストが失敗しました の件。  MatPlotLibのバージョンを [Read More]

Tracked on 2008.08.06 21:06

« TestLink:LDAPで認証 | Main | Trac一括チケット登録 »